Welcome Matrice Pilots!
Join our free DJI Matrice community today!
Sign up

Inspire X5 gimbal bent

Joined
Nov 15, 2015
Messages
4
Reaction score
0
Age
35
My X5 gimbal got bent as showed in the pic (didn't realize it, turned it on again and the gimbal worked normal, just got orientated to the side app showing evrything normal), seems like the plastic protection of the gimbal engine is somehow misplaced but I couldn't figure it out without dismounting the chip attached to the engine.
It's been quite hard finding anything useful around the internet since I guess people tend to treat their Inspires better than I did, so ended up finding this forum and hopefully someone could help me avoid the nightmare of sending it back to DJI.
Anyone could give me any tips on how to dismount it (and mount it again)? Any ideas about what it could be by the look of it? This part seems exactly the same as the X3 gimbal btw, so anything working on that should work for me! Every answer will be really helpful, thank you in advance everyone!
 
Last edited:
Joined
Nov 15, 2015
Messages
4
Reaction score
0
Age
35
Sorry about posting it on the general section, saw other post about gimbal issues here and didn't check where I was posting this.
 
Joined
Jun 28, 2015
Messages
1
Reaction score
0
Location
Canada
I've never taken one apart, but it looks like you bent a shaft. It may work now, but I think it will fail sooner rather then later. I don't believe any parts are available for it so you'll probably have to send it back for repair. Just my opinion :D
 
C

Carlsberg

Guest
I blame this on I1 marketing "The I1 is for Everyone"
Clearly it's NOT, this is a fragile and expensive piece of equipment.
 
  • Like
Reactions: lrwskyfilms
Joined
Aug 7, 2013
Messages
1,288
Reaction score
598
Sorry about posting it on the general section, saw other post about gimbal issues here and didn't check where I was posting this.
No problem - moved to X5 section.
I am afraid though your gimbal will need to be sent back to DJI for that one.
Did you say it is actually working normally though......it is actually levelling correctly and holding stabilisation even when moving the aircraft around?
 
  • Like
Reactions: Drone Ranger
Joined
Nov 15, 2015
Messages
4
Reaction score
0
Age
35
Yes, didn't want to have it on for too much time but as long as I tested it, it was working normally except for the fact of being 90 degrees to the left. It's a shame cause everything inside the plastic cover seems perfectly right and straight, it seems like it's that plastic that isn't fitting right. Just wanted to go one step further checking it before losing from a month to infinity waiting for DJI, when it could bea fair easy repair...
Found a video on youtube explaining how to takethe engine chip out, just not showing what's done afterwards, or what's inside the cover. Just the bit of informatikn I'm missing to try to repair it.
 
Joined
Nov 15, 2015
Messages
4
Reaction score
0
Age
35
Thank you so much for taking the time to explain it so well! That's exactly what I needed, gonna try and check everything at last, hopefully is not as bad as it could be.
 
Joined
Oct 6, 2014
Messages
35
Reaction score
9
Please be careful when trying to true the shafts. They are heat treated and can snap easily. I have to anneal them before working them straight and then re-temper them.

Jeremy
 

Members online

Forum statistics

Threads
2,333
Messages
24,198
Members
4,414
Latest member
TimothyCob