Welcome Matrice Pilots!
Join our free DJI Matrice community today!
Sign up

X5R gps issues (anyone else)?

Joined
Mar 20, 2014
Messages
41
Reaction score
7
When x5r is installed getting wildly fluctuating gps (constantly in and out) but with x5 on same bird stable 10+ and 15 at elevation. Anyone else seeing this issue? Did tests on the ground to confirm and 2 bird testing. Working with Dji support but thought I would ping you guys and see if this cropped up for anyone else. Could just be a lemon, but confused how the gimbal could impact gps so massively.
 
When x5r is installed getting wildly fluctuating gps (constantly in and out) but with x5 on same bird stable 10+ and 15 at elevation. Anyone else seeing this issue? Did tests on the ground to confirm and 2 bird testing. Working with Dji support but thought I would ping you guys and see if this cropped up for anyone else. Could just be a lemon, but confused how the gimbal could impact gps so massively.
Thats weird , I flew mine for the first time this morning , constant satatlite count at 11, very smooth and stable, heading back out later this avo , will have another look at sat numbers
 
  • Like
Reactions: damoncooper
Thanks, I think it may be a body specific issue I tested last night (on the ground) using another i1 pro airframe and no issue with or without x5r but the i1 pro that came with the x5r, when the x5r is in use has terrible sat issues. Without x5r or with x5 mounted, it seems fine. Really odd. Upgraded all fw but suspect now just lemon airframe and have contacted Dji support for advice on how to proceed. One other user on forum with x5r loses all sats when landing legs raised so maybe they have an assembly line issue as it relates to gps? Let me know if you notice anything in flight. Cheers!
 
Thanks, I think it may be a body specific issue I tested last night (on the ground) using another i1 pro airframe and no issue with or without x5r but the i1 pro that came with the x5r, when the x5r is in use has terrible sat issues. Without x5r or with x5 mounted, it seems fine. Really odd. Upgraded all fw but suspect now just lemon airframe and have contacted Dji support for advice on how to proceed. One other user on forum with x5r loses all sats when landing legs raised so maybe they have an assembly line issue as it relates to gps? Let me know if you notice anything in flight. Cheers!

I would say there is a grounding issue somewhere on the craft when the legs go up.

Very strange indeed.
 
  • Like
Reactions: damoncooper
When x5r is installed getting wildly fluctuating gps (constantly in and out) but with x5 on same bird stable 10+ and 15 at elevation. Anyone else seeing this issue? Did tests on the ground to confirm and 2 bird testing. Working with Dji support but thought I would ping you guys and see if this cropped up for anyone else. Could just be a lemon, but confused how the gimbal could impact gps so massively.
You will need to strip down your Inspire and get access to the upper shell. There is a cable that runs from the Ublox module (GPS) that can come loose or can have a single pin making poor connection.
If this is a new aircraft I would send it back for warranty/replacement unless you feel comfortable stripping down your own aircraft.
 
  • Like
Reactions: damoncooper
Hello, I had the exact same problem on my brand new X5R. I'm returning it (DJI approved the return and exchange). It's a hardware problem. It's a shame what happened to me and you.
 
I can confirm after having my X5R and i1Pro in the air for several batteries yesterday that I had no GPS issues at all.

15-16 sats the whole time.
 
Hello, I had the exact same problem on my brand new X5R. I'm returning it (DJI approved the return and exchange). It's a hardware problem. It's a shame what happened to me and you.

I haven't heard back from Dji. What contact method did you use and did they say they would ship a new replacement or do they wait to get the original back? Did they cover return shipping. Very unfortunate I know now 3 i1 Raws with the same issue. Good to hear some people have no issues.
 
I haven't heard back from Dji. What contact method did you use and did they say they would ship a new replacement or do they wait to get the original back? Did they cover return shipping. Very unfortunate I know now 3 i1 Raws with the same issue. Good to hear some people have no issues.
Hello. Please, send a message to [email protected] asking for a return/exchange form. I did that. They've just received mine. I'm waiting for the exchange. Regards.
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
2,714
Messages
25,366
Members
5,581
Latest member
bmj