Welcome Matrice Pilots!
Join our free DJI Matrice community today!
Sign up

GH4 - no video on M600 Pro

Joined
Feb 21, 2018
Messages
228
Reaction score
55
Age
64
Attempting to connect a GH4 to the Matrice HDMI, for use with a RoninMX Gimble setup. Currently, unable to get GH4 to display on either a iPad Pro 10 or a CrystalSky UB 7.85.

I've gone through long methods to verify it's not LB or the Matrice 600. I've stepped through every GH4 Menu option, nothing pertains to HDMI port other than normal TV options. I can connect a MacBook through the HDMI and it will immediately display on the RC's Display. I can also connect a Canon DSLR and it will display.

Does work on TV: When connecting GH4 to a TV, it does display correctly. When breaking & making HDMI connections on the M600 you can see the GH4's view screen blink off 1-2 seconds and then back on... normally the action when the HDMI Port is switched in the circuit. But won't display on the RC's Monitor. I was leaning toward resolution out of range, but there switching from Auto, 4K, 1080, 720 makes no difference.

I thought maybe GH4 Firmware... it was 2.5 so I upgraded to 2.7 with no change in behavior.
I keep reading how many love the GH4 on the M600 but I'm having terrible luck getting it to be ON.

I've read recently several WEB articles on the difficulties getting the GH4 to display correctly through it's HDMI port. Not specifically the M600, but several other projects for cinema. I've considered sending GH4 in for repair, but not certain that would resolve anything.
 
Last edited:
Joined
Feb 21, 2018
Messages
228
Reaction score
55
Age
64
Resolved the issue... unknown to me, HDMI has several different channels/protocols that it can connect, it doesn't use just HDMI. So it is possible for a Camera or device to connect properly to a TV and not to a different device. The GH4 would connect to a TV, but not Lightbridge2.

Discussions with a Camera Repair Tech (Panasonic Eng), it was indicated the HDMI Chipset on the GH4 is bad, even though it connects with a TV, it won't connect to LB module.

In brief, this requires a HDMI Chipset replacement within the GH4 for estimated repair of $290.
** When camera returns, I'll verify HDMI connection.
 
Joined
Feb 21, 2018
Messages
228
Reaction score
55
Age
64
Camera sent off to Repair, and increased to $330 due to a damaged HDMI socket & Chip set.

For those with similar experiences... Testing HDMI to a TV will not verify proper HDMI operation for other devices such as Lightbridge 2 connections. They run on different protocols within the HDMI protocol suite.... similar to how BT has a suite of protocols that determine what connectivity it provides.

It was a toss-up to repair or purchase another GH4 on eBay for avg price of $650.
Other than lightly using the GH4 since purchase this Winter on eBay, it was sitting & waiting for the Ronin MX.
Toyed with just getting another one, but may have gotten another one with same issues, so went with repair.
 

Recent Posts

Members online

No members online now.

Forum statistics

Threads
2,482
Messages
24,680
Members
4,954
Latest member
Mark