Welcome Matrice Pilots!
Join our free DJI Matrice community today!
Sign up

Matrice 210 gimbal errors

Joined
Mar 29, 2022
Messages
1
Reaction score
0
Age
43
I have a Matrice 210 v1 with a dual gimbal setup, with a Z30 and an XT (with adapter.)

When I installed the cameras as they are shown in every photo ever of this setup, with the Z30 on the left (Gimbal Connector 2), and the XT on the right (Gimbal Connector 1), I got a popup message in DJI Pilot saying that I would get better performance with the Z30 in Gimbal Connector 1.

So I swapped them and rebooted everything. But now I am getting a "Gimbal Shake Error" popup message, immediately upon startup, before moving anything, while still on the ground.

I cannot visibly detect any shaking. It all looks and sounds somewhat normal to me. Does anyone know how to resolve this error?

Also, when I try to calibrate the XT gimbal in Pilot, I get errors that this cannot complete as well, and I do not know why.

Any ideas?

Thanks
 
Joined
Feb 21, 2018
Messages
228
Reaction score
54
Age
64
Just to verify, was the XT Payload upgraded to XTv2 by DJI Service... or was it a Version2 purchased?

The XT adapter corrects the connection interface, but the XT still needs to be Updated as well. That's been a misunderstanding in past.

The DJI Service update if I recall on mine was around $280.

Beyond that, I don't have any suggestions on your Pilot App Errors.
 
Joined
Jul 11, 2022
Messages
4
Reaction score
0
Age
52
dont know if you got an answer, but i went through this too!
Here is the fix, the adapter ring has its own firware, if you have the latest firmware on the adapter ring, you have to downgrade to the previous version. The updated version was meant for the 210 V2. The 210 V2 uses the older ring adapter firmware.
Once you downgrade, she'll run beautiful!
Mike
 
Joined
Feb 21, 2018
Messages
228
Reaction score
54
Age
64
dont know if you got an answer, but i went through this too!
Here is the fix, the adapter ring has its own firware, if you have the latest firmware on the adapter ring, you have to downgrade to the previous version. The updated version was meant for the 210 V2. The 210 V2 uses the older ring adapter firmware.
Once you downgrade, she'll run beautiful!
Mike
Good to know Mike, thanks for that info.
Mine is a V1, and an older adapter so hasn't been noticed.
 
Joined
Jul 11, 2022
Messages
4
Reaction score
0
Age
52
I have a Matrice 210 v1 with a dual gimbal setup, with a Z30 and an XT (with adapter.)

When I installed the cameras as they are shown in every photo ever of this setup, with the Z30 on the left (Gimbal Connector 2), and the XT on the right (Gimbal Connector 1), I got a popup message in DJI Pilot saying that I would get better performance with the Z30 in Gimbal Connector 1.

So I swapped them and rebooted everything. But now I am getting a "Gimbal Shake Error" popup message, immediately upon startup, before moving anything, while still on the ground.

I cannot visibly detect any shaking. It all looks and sounds somewhat normal to me. Does anyone know how to resolve this error?

Also, when I try to calibrate the XT gimbal in Pilot, I get errors that this cannot complete as well, and I do not know why.

Any ideas?

Thanks
I have a Matrice 210 v1 with a dual gimbal setup, with a Z30 and an XT (with adapter.)

When I installed the cameras as they are shown in every photo ever of this setup, with the Z30 on the left (Gimbal Connector 2), and the XT on the right (Gimbal Connector 1), I got a popup message in DJI Pilot saying that I would get better performance with the Z30 in Gimbal Connector 1.

So I swapped them and rebooted everything. But now I am getting a "Gimbal Shake Error" popup message, immediately upon startup, before moving anything, while still on the ground.

I cannot visibly detect any shaking. It all looks and sounds somewhat normal to me. Does anyone know how to resolve this error?

Also, when I try to calibrate the XT gimbal in Pilot, I get errors that this cannot complete as well, and I do not know why.

Any ideas?

Thanks
dont know if you got an answer, but i went through this too!
Here is the fix, the adapter ring has its own firware, if you have the latest firmware on the adapter ring, you have to downgrade to the previous version. The updated version was meant for the 210 V2.
dont know if you got an answer, but i went through this too!
Here is the fix, the adapter ring has its own firware, if you have the latest firmware on the adapter ring, you have to downgrade to the previous version. The updated version was meant for the 210V1 The 210 V2 uses the older ring adapter firmware.
Once you downgrade, she'll run beautiful!
Mike
 

Members online

No members online now.

Forum statistics

Threads
2,421
Messages
24,456
Members
4,800
Latest member
twoheadlines